Breaking News
Home / Mobile / Apple offering ‘last compatible’ app version for older versions of iOS

Apple offering ‘last compatible’ app version for older versions of iOS

With ions 7 about to make it a lot-awaited debut nowadays and the release of two new phones waiting within the wings, spare a thought for devices which can be near obsolete thanks to them being unable to improve to up to date operating gadget variations. It has now been printed that Apple does, actually, spare just a few thoughts for them. the company will let customers with older devices download an older version of functions which might be appropriate with their phones.

The function used to be discovered via a Reedit consumer who was once experimenting with a 2nd-gen iPod contact he owns. He tried to install Integra onto the device and was served with a message that asked him if he wish to obtain an older version of this utility. “the current model requires ions 5.zero or later, but that you could download the final suitable version,” the message read.

 

Older iOS version? No problem!

Older ions model? No drawback!

This seems like a delightful move from Apple. the corporate labored around compatibility considerations to nonetheless preserve customers on older variations in the loop. App developers are going to keep p.c. with the more recent ions variations that Apple releases periodically because it makes extra feel for them to increase purposes for more customers. alternatively, with every new ions version that pops up, there’s going to be one version, released years in the past, as a way to develop into obsolete however some people will proceed to own devices that run on the older variations of the OS.

Hence the “closing compatible app version”. the theory is probably not a fully fool-proof one, especially when considerations like API compatibility pop up. on the other hand, with the bare bones options of the ultimate compatible version of the app doing just superb, it will have to be more than sufficient for users.